This repository has been archived on 2021-01-26. You can view files and clone it, but cannot push or open issues or pull requests.
gentoo-overlay/app-emulation/vagrant-bin/vagrant-bin-1.9.3.ebuild

40 lines
715 B
Bash

# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $
EAPI=5
MY_PN=${PN/-bin/}
inherit unpacker eutils
DESCRIPTION="Tool for building and distributing virtual machines"
HOMEPAGE="http://vagrantup.com/"
SRC_URI="https://releases.hashicorp.com/${MY_PN}/${PV}/${MY_PN}_${PV}_x86_64.deb"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
S="${WORKDIR}/opt/${MY_PN}"
DEPEND=""
RDEPEND="${DEPEND}
app-arch/libarchive
net-misc/curl
"
RESTRICT="mirror"
src_unpack() {
unpack_deb ${A}
}
src_install() {
local dir="/opt/${MY_PN}"
dodir ${dir}
cp -ar ./* "${ED}${dir}" || die "copy files failed"
make_wrapper "${MY_PN}" "${dir}/bin/${MY_PN}"
}