version bump

This commit is contained in:
Tamás Gérczei 2020-04-12 19:17:24 +02:00
parent c3d5974d72
commit 7046e2aea4
5 changed files with 126 additions and 2 deletions

View File

@ -1,3 +1,7 @@
AUX initd_znapzend 343 BLAKE2B eddce54c04e1371b7626cf33ead2a72195660fcaff53f14bbeb860c133575dddb1afee8cde7cddb7734268249cfa199469ceaf65da288614eeaf528ea40d45c6 SHA512 52d0329fa6e660ea994712ea032024537fcbb705932e98a454e87ccaae99ba74538c89ab4ad037e552d7ce7d355945b27624c027d92c1bf77d702f6108e63656
AUX 001-flatten_version.patch 1136 BLAKE2B d87a5e275f358aee719910cc64d22a74026686a1061a592bd21011001079fb62cdd2370d4e995b9d9787ed9a09b7e83916beb50c55a5bcac4fac135aba7013f0 SHA512 3a895ffefee7a5d1545294179c7f335847c7237d22b6c74998ce91524a31fb6e9778a580aafc75f662b47a14998ac8110f3bd9b632d2da1147e3ffeb80d8aa46
AUX 002-libdir.patch 1155 BLAKE2B 86d883890aa2879cd55e3b95d4ee95de651481e41e0fd9f31781bfc634d472945262af4d45ba40e6d6697911f80b31c2771f50c36804f653123a798c1a453fec SHA512 f321644c649094d4bbfe54ddb2f890b007f986bd381b78843e5ad37c7ef049f468a4954e244fd165231606637a1502b7eb4e70fff793b134363eb61f22abb711
AUX initd_znapzend 343 BLAKE2B 5985e7c0b1a761a0a79dd5685d84ec72e242f603e1c7ec6fc6b729118f8b77b50cedd0c4301a7ff17460b82d0c989ec5386df251a3e0ab57f56c9debbae52f4e SHA512 6c76ad0e42cb6de3df6cd846bc680623fb31faaac54bc07e83f66afadaaddcd6fc374984d7b7a6a5393751dcb39bc3843810436ccb4fae4c2cf06df30adbadf9
DIST znapzend-0.19.1.tar.gz 3115740 BLAKE2B a39e0e643f94e492cba0f230197a5600fbd1e5292eabcf9513f8d8ef355c7d9294acb5ba2a1d329cf60eee0074db0f3fc39baf94fe316d56f4b21cfb049a3159 SHA512 7cfd00ab813571f2b29ae51a83281f1093914fdb4a5dfcd59768d017b14110ffb969cf13052eed0de06df6c072e689f4ab041ca310e05d3e90c0bbc2f174e9cc
DIST znapzend-0.20.0.tar.gz 314889 BLAKE2B 10da875be758b8f317b73a7f7623c6ca1a77e9092487b8c84e27b97c73bb074c81d686ae03aa7254cda645c83e4c7a6d7ef28d79af1d0e4cf5cf1204cf32b67a SHA512 d0b7a488412dc9231f7fdf679bef130e2d66bcc3cfd7c64ae74f4cd5cbf7d107e9d5418a5b19b931f488f05fa576d3b049f47b58caea2d71689eb5dad1a31c90
EBUILD znapzend-0.19.1.ebuild 1061 BLAKE2B dcaf9eeaaa24d46c70ecf4a9a761adc514e575dbba484e7e7d54ded70866a3a19d9a71911b366e5287fbc907591522c78128bf922b6a8c37cf7a3a08c34635b2 SHA512 8a60f496c5b2f23c428afa82a382261b218cd4adc4f057c2dd07bfe8b041b99c1ef650f8209dc07f8ef30e3149a55ebecf564ad5bee15bd2c78f892102c60e3b
EBUILD znapzend-0.20.0.ebuild 1241 BLAKE2B 462ee2569c9bfcfa72f941d315230a11be59296c00513668342c8ce213486f256c298a774f332d8fc45e138c8a1103194549cf6ae698b7958536e4ab8ae5f8dc SHA512 6ff937099d4e250301c5e6f1538522a20c8fd2d2781c77093d434493d14f75729946967208f30ef45fa75c8ef98a6c52fc6fabcd70d7d956578a2a369b3282a6

View File

@ -0,0 +1,33 @@
--- bin/znapzend.orig 2020-04-12 17:39:10.102455621 +0200
+++ bin/znapzend 2020-04-12 17:39:40.963918077 +0200
@@ -7,7 +7,7 @@
use Pod::Usage;
use ZnapZend;
-my $VERSION = '0.dev'; #VERSION
+my $VERSION = '0.20.0'; #VERSION
my %featureMap = map { $_ => 1 } qw(pfexec sudo oracleMode recvu compressed sendRaw lowmemRecurse zfsGetType skipIntermediates);
sub main {
--- bin/znapzendzetup.orig 2020-04-12 17:39:20.900680099 +0200
+++ bin/znapzendzetup 2020-04-12 17:39:51.585130973 +0200
@@ -9,7 +9,7 @@
use Scalar::Util qw(blessed);
use Mojo::Base -strict;
use ZnapZend::Config;
-my $VERSION = '0.dev'; #VERSION
+my $VERSION = '0.20.0'; #VERSION
my @ROOT_EXEC_OPTIONS = qw(pfexec sudo rootExec=s debug features=s);
my %featureMap = map { $_ => 1 } qw(pfexec sudo lowmemRecurse zfsGetType);
--- bin/znapzendztatz.orig 2020-04-12 17:39:28.064817825 +0200
+++ bin/znapzendztatz 2020-04-12 17:40:02.618352124 +0200
@@ -9,7 +9,7 @@
use Mojo::Base -strict;
use ZnapZend::Config;
use ZnapZend::ZFS;
-my $VERSION = '0.dev'; #VERSION
+my $VERSION = '0.20.0'; #VERSION
my $zConfig;
my $zZfs;
my $zTime = ZnapZend::Time->new();

View File

@ -0,0 +1,30 @@
--- bin/znapzend.orig 2020-04-12 19:02:42.241779113 +0200
+++ bin/znapzend 2020-04-12 19:04:18.138724487 +0200
@@ -1,6 +1,6 @@
#!/usr/bin/env perl
-use lib qw(); # PERL5LIB
+use lib qw(/usr/share/znapzend/perl5);
use FindBin; use lib "$FindBin::Bin/../lib", "$FindBin::Bin/../thirdparty/lib/perl5"; # LIBDIR
use Getopt::Long qw(:config posix_default no_ignore_case);
--- bin/znapzendzetup.orig 2020-04-12 19:02:53.930016221 +0200
+++ bin/znapzendzetup 2020-04-12 19:04:13.759635655 +0200
@@ -1,6 +1,6 @@
#!/usr/bin/env perl
-use lib qw(); # PERL5LIB
+use lib qw(/usr/share/znapzend/perl5);
use FindBin; use lib "$FindBin::Bin/../lib", "$FindBin::Bin/../thirdparty/lib/perl5"; # LIBDIR
use Getopt::Long qw(:config posix_default no_ignore_case pass_through);
--- bin/znapzendztatz.orig 2020-04-12 19:03:04.731235336 +0200
+++ bin/znapzendztatz 2020-04-12 19:04:08.917537425 +0200
@@ -1,6 +1,6 @@
#!/usr/bin/env perl
-use lib qw(); # PERL5LIB
+use lib qw(/usr/share/znapzend/perl5);
use FindBin; use lib "$FindBin::Bin/../lib", "$FindBin::Bin/../thirdparty/lib/perl5"; # LIBDIR
use Getopt::Long qw(:config posix_default no_ignore_case);

View File

@ -2,7 +2,7 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
command="/opt/bin/znapzend"
command="/usr/bin/znapzend"
pidfile="/var/run/${RC_SVCNAME}.pid"
if [ -e /etc/default/${RC_SVCNAME} ]; then

View File

@ -0,0 +1,57 @@
# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
inherit eutils
DESCRIPTION="ZFS backup with remote capabilities and mbuffer integration"
HOMEPAGE="https://github.com/oetiker/znapzend"
SRC_URI="${HOMEPAGE}/releases/download/v${PV}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""
RDEPEND="${DEPEND}"
src_prepare() {
epatch "${FILESDIR}/001-flatten_version.patch"
epatch "${FILESDIR}/002-libdir.patch"
}
src_configure() {
PERL5LIB="/usr/share/${PN}/perl5" \
econf --prefix=/opt --libdir="/usr/share/${PN}/perl5"
}
src_compile() {
emake
}
src_install() {
exeinto /usr/bin
doexe bin/*
insinto /etc/default
newins init/${PN}.default ${PN}
insinto /usr/share/${PN}/perl5
doins lib/ZnapZend.pm
doins -r lib/ZnapZend
insinto /usr/share/${PN}/perl5
doins -r thirdparty/lib/perl5/*
doman man/znapzend{,zetup,ztatz}.1
newinitd ${FILESDIR}/initd_${PN} ${PN}
}
pkg_postinst() {
elog ""
elog "This software release depends on modules no longer available through Portage."
elog "Since it will automatically obtain them from CPAN, they will be placed under"
elog "'/opt/lib' in order not to interfere with the rest of the system."
elog ""
}